Thursday, January 12, 2012

Do you know the IS01?

I have an IS01. This device is the first Android phone made ​​by Sharp. IS01 are loved and widely known as known as eyeglasses case.

But this device is AndroidOS1.6. And that was not updated to 2.1.
http://japanese.engadget.com/2010/03/29/au-android-is01-5/

Changing the subject, I am made an app that JustPlayer. Of course people look at this blog will know.


Although JustPlayer made ​​last year. Support more than was originally SDK1.6.
But when the corresponding Gingerbread, 1.6 lost its support.
The reason I wanted to use AudioEffect.

After a while, we implemented the process of switching to match in the OS using the AudioEffect. Could correspond to 2.1 and 2.2 because of this.

Unfortunately at this time, 1.6 are excluded. The reason the test was cumbersome.

So, today is not compatible decided to challenge the IS01.




Corresponding to the code is as follows: IS01, you must isolate the code that is not supported.

if(Build.VERSION.SDK_INT>8){
 return mMediaPlayer.getAudioSessionId();
}
else {
 return -1;
}


This is a common technique in multiple versions support not only when IS01.


But this is not sufficient in IS01.
I discourage you java.lang.VerifyError.


The reason is because this will make an error by steping the class would not support the method to be executed separately by IF.
This is perhaps because it does not depend on the terminal the other device that have occurred in me.

Therefore, methods that do not support defining a separate class, so no need to read directly.

This way:

if(Build.VERSION.SDK_INT>8){
 return MediaPlayerHelper.getAudioSessionId(mMediaPlayer);
}
else {
 return -1;
}


Is tedious, and would be doing today.
You were great.
But now safely move!

APK is not sent to separate and create this joy to my friends so.
I thought very pleased,,
Did not work.

Why? Execution environment for running but I am! The difference is APK approved or not.

I installed the app adb commands to try and approved.
Then, fraud has been terminated in error.

java.lang.VerifyError: android.support.v4.app.FragmentManagerImpl


What can I say? Error has CompatiblityAPI. What I use bad.
I know this is up to 1.6 are supported.
In the end, because I do not know how to resolve, we decided to give up.


In addition, there is a hint I want to try something.






1 comment:

  1. Thank you for your app.

    I use JustPlayer with Ampache.

    ReplyDelete